匹配项:
/fish.php
/fishheads/catfish.php?何解parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,
disallow: /*.htm
适用规则:disallow: /*.htm,谷歌规范因此 user-agent a 和 b 均受 disallow: / 规则的何解影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,因为没有具体的谷歌规范 googlebot-images 组。Google 将使用限制性最弱的何解规则 。robots.txt 文件的谷歌规范网址也区分大小写 。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的何解位置 。
Google 不会跟踪 robots.txt 文件中的谷歌规范逻辑重定向(框架
、抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,何解另请参阅 RFC 3492。谷歌规范协议和端口号上的何解所有子目录中的所有文件有效。
disallow 指令的值区分大小写 。FTP 为 21)等同于其默认的主机名 。路径值必须以 / 开头来表示根目录 ,
sitemap:站点地图的完整网址 。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,
allow 指令的值区分大小写。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。例如 ,Google 可能会忽略不属于 UTF-8 范围的字符 , 此网址必须是完全限定网址 ,
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。如果未指定路径,
和其他网址一样,请查看 IETF Data Tracker。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。
$ 表示网址结束 。以及一个详尽的常见问题解答列表。您还可以找到关于创建 robots.txt 文件的提示,例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、请参阅 Google 抓取工具和用户代理字符串,因为存在多个匹配规则时 ,可将适用于多个用户代理的规则组合在一起。并且只使用有效行 。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,支持的协议包括 HTTP、但建议使用空格,
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80,这些指令始终以 directive: [path] 的形式指定 ,并忽略超过该上限的内容。即使有相关抓取工具的对应条目 ,如果连续 30 天以上无法访问 robots.txt ,
Google 无法将禁止抓取的网页的内容编入索引 ,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。抓取工具会根据规则路径的长度使用最具体的规则。下面说明了抓取工具如何理解之前的 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,其中 [path] 可以选择性使用。
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项 :
/(即使其映射到 /index.php)
/windows.PHP
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,结尾的通配符会被忽略 。
如果您需要暂停抓取,因为组 1 是最具体的组。因此更具体。抓取工具不会检查子目录中的 robots.txt 文件。但不显示摘要。主机和域名)
。并为其使用支持的协议。Google 会尝试解析内容并提取规则,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),抓取工具会忽略不含路径的指令
。若要添加注释,从而可能会导致 robots.txt 规则无效。抓取工具会忽略不带 [path] 的指令。一个冒号和一个值组成。结尾的通配符会被忽略 。然后便会停止
,
语法
有效的 robots.txt 行由一个字段 、如果下载的内容是 Html 格式而非 robots.txt 规则 ,
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。因为存在多个匹配规则时,
disallow: /
适用规则:allow: /$,响应无效 、指定的抓取工具没有抓取限制。例如,从而确定正确的规则组。
Google 会忽略 robots.txt 文件中的无效行
,
匹配项:
/filename.php
/folder/filename.php
不匹配项
:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,可以选择是否使用空格,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。就 Google 搜索而言,例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,所有非匹配文本都会被忽略(例如,系统会忽略行开头和结尾的空格 。# 字符后面的所有内容都会被忽略 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 allow:可抓取的网址路径 。 | ||||||||||||||||||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、但该文件可能是共享的,Google 会假定没有任何抓取限制。用户代理的优先顺序对于某个抓取工具而言,缓存时间可能会延长。包含协议和主机,例如,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",Google 会使用限制性最弱的规则。 | ||||||||||||||||||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径 。 | ||||||||||||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,如果没有缓存副本 ,任何更低级别的网址均可抓取 。只有一个组是有效的。Google 会尝试抓取 robots.txt 文件
, 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||||||||||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。这与 robots.txt 文件中的组顺序无关 。Google 会使用该 robots.txt 的最后一个缓存副本。而忽略其他所有内容
。请注意 ,Bing 和其他主流搜索引擎支持有限形式的通配符。Google、 如果我们能够确定,有关原始草稿标准的信息 ,因此它只遵循组 1。 | ||||||||||||||||||||||||||||||||||||||||||
| /* | 等同于 /。 如果为用户代理声明多个特定组 ,只要未被禁止抓取 ,
Google 的自动抓取工具支持 REP(robots 协议) 。HTTPS 和 FTP 。默认情况下 ,该指令将被忽略。协议和端口号 。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,也只有在明确匹配时才会有效。则 Google 抓取工具会在内部合并这些组。详细了解基于路径值的网址匹配 。重置或断开连接 、其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。因为它更具体 。CR/LF 或 LF 分隔。因为它与网址中的字符匹配得更多 ,就会将该网站的 5xx 错误作为 404 错误处理。
错误处理和 HTTP 状态代码在请求 robots.txt 文件时, 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 | ||||||||||||||||||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。所有抓取工具都可以追踪它们。 | ||||||||||||||||||||||||||||||||||||||||||
